summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-14 17:48:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-14 17:50:17 +0200
commit2d3422fdb37800217b663d8999ee0a380b462267 (patch)
tree38c5d5f0d72c53faeb632b17cc547a0d3c655005 /dev-ml/dose3
parentx11-misc/slim: removed consolekit USE mask for stable (diff)
downloadgentoo-2d3422fdb37800217b663d8999ee0a380b462267.tar.gz
gentoo-2d3422fdb37800217b663d8999ee0a380b462267.tar.bz2
gentoo-2d3422fdb37800217b663d8999ee0a380b462267.zip
dev-ml/dose3: fix build with latest extlib.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ml/dose3')
-rw-r--r--dev-ml/dose3/dose3-3.3.ebuild3
-rw-r--r--dev-ml/dose3/files/extlib.patch12
2 files changed, 15 insertions, 0 deletions
diff --git a/dev-ml/dose3/dose3-3.3.ebuild b/dev-ml/dose3/dose3-3.3.ebuild
index 808c7afc8e27..f9ac6f602445 100644
--- a/dev-ml/dose3/dose3-3.3.ebuild
+++ b/dev-ml/dose3/dose3-3.3.ebuild
@@ -4,6 +4,8 @@
EAPI=5
+inherit eutils
+
MY_P="${P/_beta/-beta}"
DESCRIPTION="Library and a collection of tools to perform la large spectrum of analysis on package repositories"
HOMEPAGE="http://dose.gforge.inria.fr/public_html/"
@@ -39,6 +41,7 @@ S="${WORKDIR}/${MY_P}"
src_prepare() {
sed -e 's/INSTALLOPTS=-s/INSTALLOPTS=/' -i Makefile.config.in || die
+ has_version '>=dev-ml/extlib-1.7' && epatch "${FILESDIR}/extlib.patch"
}
src_configure() {
diff --git a/dev-ml/dose3/files/extlib.patch b/dev-ml/dose3/files/extlib.patch
new file mode 100644
index 000000000000..f4a16ded682a
--- /dev/null
+++ b/dev-ml/dose3/files/extlib.patch
@@ -0,0 +1,12 @@
+Index: dose3-3.3/doseparse/stdOptions.ml
+===================================================================
+--- dose3-3.3.orig/doseparse/stdOptions.ml
++++ dose3-3.3/doseparse/stdOptions.ml
+@@ -20,6 +20,7 @@ include Util.Logging(struct let label =
+ module type Ot = sig
+ val options :
+ ?usage:string ->
++ ?status:int ->
+ ?version:string ->
+ ?suppress_usage:bool ->
+ ?suppress_help:bool ->