summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-07-12 19:23:21 -0600
committerChristoph Junghans <junghans@gentoo.org>2022-07-12 19:23:51 -0600
commitaab3a914e14666ca962175f3b6a4ad64589e79ed (patch)
tree1057e3a3936f4a5f7f98d74bb5985d114b14f75f /dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
parentnet-libs/uhttpmock: Version bump to 0.5.5 (diff)
downloadgentoo-aab3a914e14666ca962175f3b6a4ad64589e79ed.tar.gz
gentoo-aab3a914e14666ca962175f3b6a4ad64589e79ed.tar.bz2
gentoo-aab3a914e14666ca962175f3b6a4ad64589e79ed.zip
dev-ml/gapi-ocaml: initial commit
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild')
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..156be6ded14c
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ <dev-ml/yojson-2:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"
+PATCHES=( "${FILESDIR}/${P}-ounit2.patch" )