summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-15 10:12:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-15 10:49:42 +0200
commitd886061d8cac61620d2563376bf6bc2dc35ec957 (patch)
treedbc4bc0b7f0636add9e3e77b9cfa982bf0eb01b0 /dev-ml/markup/markup-0.7.5.ebuild
parentwww-client/firefox: amd64 stable wrt bug #621722 (diff)
downloadgentoo-d886061d8cac61620d2563376bf6bc2dc35ec957.tar.gz
gentoo-d886061d8cac61620d2563376bf6bc2dc35ec957.tar.bz2
gentoo-d886061d8cac61620d2563376bf6bc2dc35ec957.zip
dev-ml/markup: bump to 0.7.5
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/markup/markup-0.7.5.ebuild')
-rw-r--r--dev-ml/markup/markup-0.7.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/markup/markup-0.7.5.ebuild b/dev-ml/markup/markup-0.7.5.ebuild
new file mode 100644
index 000000000000..6936fe4a8367
--- /dev/null
+++ b/dev-ml/markup/markup-0.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}p1"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/lwt:=[ocamlopt]
+ >=dev-ml/uutf-1.0:=[ocamlopt]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/ocamlbuild"
+S="${WORKDIR}/${PN}.ml-${PV}"
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+ use doc && dohtml doc/html/*
+}