summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-28 10:50:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-29 12:05:38 +0200
commitc02297c9c11addcd6f954b564e58b148f0bc2872 (patch)
treeafe3e56d8f1dfdd779b1eab49b488a809a72fc0e /dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
parentdev-ml/ocaml-stdint: bump to 0.4.1 (diff)
downloadgentoo-c02297c9c11addcd6f954b564e58b148f0bc2872.tar.gz
gentoo-c02297c9c11addcd6f954b564e58b148f0bc2872.tar.bz2
gentoo-c02297c9c11addcd6f954b564e58b148f0bc2872.zip
dev-ml/ocaml-dispatch: bump to 0.4.0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild')
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
new file mode 100644
index 000000000000..562ef548b9a1
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-ml/result:=
+ dev-lang/ocaml:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+"
+
+src_compile() {
+ jbuilder build -p dispatch || die
+}
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall dispatch
+}