summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 01:00:57 +0000
committerSam James <sam@gentoo.org>2020-10-17 01:01:33 +0000
commit236ecc6da4bf3ffe0986bd2f2014e61225a2c095 (patch)
tree7805760dc9008d63fb8a47d23ac3e46b8165fa2d /dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
parentdev-ml/camomile: bump to 1.0.2 (fix >=4.10.0 compat) (diff)
downloadgentoo-236ecc6da4bf3ffe0986bd2f2014e61225a2c095.tar.gz
gentoo-236ecc6da4bf3ffe0986bd2f2014e61225a2c095.tar.bz2
gentoo-236ecc6da4bf3ffe0986bd2f2014e61225a2c095.zip
dev-ml/ocaml-gettext: bump to 0.4.2 (fix >=4.10.0 compat)
Bug: https://bugs.gentoo.org/749149 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild')
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
new file mode 100644
index 000000000000..ffcd1505d09d
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gettext"
+inherit dune
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +ocamlopt"
+
+BDEPEND="dev-ml/cppo"
+RDEPEND="
+ >=dev-ml/camomile-0.8.3:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ sys-devel/gettext
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
+"
+
+src_install() {
+ dune_src_install
+
+ # Hack for now until we get --mandir in dune.eclass
+ cd "${ED}/usr/man" || die
+ doman man1/* man5/*
+ rm -r "${ED}/usr/man" || die
+}