summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:06:20 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:30 +1100
commit72e9d070bbdb2ba684cba44e067417bc0da0c91a (patch)
tree2cadee9e461e4e59134a762b2694e702b4b730d3 /dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
parentdev-ml/opam-core: Dependency of dev-ml/opam-format (diff)
downloadgentoo-72e9d070bbdb2ba684cba44e067417bc0da0c91a.tar.gz
gentoo-72e9d070bbdb2ba684cba44e067417bc0da0c91a.tar.bz2
gentoo-72e9d070bbdb2ba684cba44e067417bc0da0c91a.zip
dev-ml/opam-file-format: Dependency of dev-ml/opam-client
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
new file mode 100644
index 000000000000..3adeb20ac869
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake byte $(usex ocamlopt native "")
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
+}