summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 00:28:35 +0000
committerSam James <sam@gentoo.org>2021-04-21 02:09:38 +0000
commit516283fd76d8482c26f18b050a183180c42c93e2 (patch)
tree52a953b0c54ff876d28d633e6191b485a3357ccf /dev-ml/reactiveData/reactiveData-9999.ebuild
parentdev-ml/reactiveData: port to EAPI 7 (diff)
downloadgentoo-516283fd76d8482c26f18b050a183180c42c93e2.tar.gz
gentoo-516283fd76d8482c26f18b050a183180c42c93e2.tar.bz2
gentoo-516283fd76d8482c26f18b050a183180c42c93e2.zip
dev-ml/reactiveData: drop 9999
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/reactiveData/reactiveData-9999.ebuild')
-rw-r--r--dev-ml/reactiveData/reactiveData-9999.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ml/reactiveData/reactiveData-9999.ebuild b/dev-ml/reactiveData/reactiveData-9999.ebuild
deleted file mode 100644
index f016dcff52af..000000000000
--- a/dev-ml/reactiveData/reactiveData-9999.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit opam
-
-DESCRIPTION="Functional reactive programming with incremental changes in data structures"
-HOMEPAGE="https://github.com/ocsigen/reactiveData"
-
-if [[ "${PV#9999}" != "${PV}" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
-else
- SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-3-with-linking-exception"
-SLOT="0/${PV}"
-IUSE="+ocamlopt"
-
-RDEPEND="dev-ml/react:="
-DEPEND="${RDEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
-"
-
-src_compile() {
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
-}