summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/reactiveData/reactiveData-9999.ebuild')
-rw-r--r--dev-ml/reactiveData/reactiveData-9999.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ml/reactiveData/reactiveData-9999.ebuild b/dev-ml/reactiveData/reactiveData-9999.ebuild
deleted file mode 100644
index f016dcff52af..000000000000
--- a/dev-ml/reactiveData/reactiveData-9999.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit opam
-
-DESCRIPTION="Functional reactive programming with incremental changes in data structures"
-HOMEPAGE="https://github.com/ocsigen/reactiveData"
-
-if [[ "${PV#9999}" != "${PV}" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ocsigen/reactiveData"
-else
- SRC_URI="https://github.com/ocsigen/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="LGPL-3-with-linking-exception"
-SLOT="0/${PV}"
-IUSE="+ocamlopt"
-
-RDEPEND="dev-ml/react:="
-DEPEND="${RDEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
-"
-
-src_compile() {
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
-}