summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-29 13:24:34 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-30 16:24:26 +0200
commit53bd2701be99a2f07356afe8d9d1d7efe4ad442c (patch)
tree2cbeb81b85d63f3ca015f4c45054e03ec72dd5cf /dev-ml/tyxml/tyxml-4.6.0.ebuild
parentapp-emacs/yaml: bump to 0.5.4 (diff)
downloadgentoo-53bd2701be99a2f07356afe8d9d1d7efe4ad442c.tar.gz
gentoo-53bd2701be99a2f07356afe8d9d1d7efe4ad442c.tar.bz2
gentoo-53bd2701be99a2f07356afe8d9d1d7efe4ad442c.zip
dev-ml/tyxml: bump to 4.6.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/tyxml/tyxml-4.6.0.ebuild')
-rw-r--r--dev-ml/tyxml/tyxml-4.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/tyxml/tyxml-4.6.0.ebuild b/dev-ml/tyxml/tyxml-4.6.0.ebuild
new file mode 100644
index 000000000000..0064acfb4d31
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A library for building correct HTML and SVG documents"
+HOMEPAGE="https://github.com/ocsigen/tyxml/"
+SRC_URI="https://github.com/ocsigen/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/markup:=
+ dev-ml/ppxlib:=
+ dev-ml/uutf:=
+ dev-ml/re:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? (
+ dev-ml/alcotest
+ dev-ml/reason
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.5.0-gentoo.patch )