summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/tyxml/tyxml-4.6.0.ebuild')
-rw-r--r--dev-ml/tyxml/tyxml-4.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/tyxml/tyxml-4.6.0.ebuild b/dev-ml/tyxml/tyxml-4.6.0.ebuild
new file mode 100644
index 000000000000..0064acfb4d31
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A library for building correct HTML and SVG documents"
+HOMEPAGE="https://github.com/ocsigen/tyxml/"
+SRC_URI="https://github.com/ocsigen/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/markup:=
+ dev-ml/ppxlib:=
+ dev-ml/uutf:=
+ dev-ml/re:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ test? (
+ dev-ml/alcotest
+ dev-ml/reason
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.5.0-gentoo.patch )