summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-04 17:11:48 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-04 17:11:48 +0200
commitc6f38e0711159034a5e89ae1c9cf2b5ee552b73e (patch)
tree5cf8cc7ad3c90532a5c259e92c91c6609875aecb /dev-ml/utop/utop-2.9.2.ebuild
parentdev-ml/utop: enable Emacs support (diff)
downloadgentoo-c6f38e0711159034a5e89ae1c9cf2b5ee552b73e.tar.gz
gentoo-c6f38e0711159034a5e89ae1c9cf2b5ee552b73e.tar.bz2
gentoo-c6f38e0711159034a5e89ae1c9cf2b5ee552b73e.zip
dev-ml/utop: bump to 2.9.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/utop/utop-2.9.2.ebuild')
-rw-r--r--dev-ml/utop/utop-2.9.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-ml/utop/utop-2.9.2.ebuild b/dev-ml/utop/utop-2.9.2.ebuild
new file mode 100644
index 000000000000..cd05e5fc7a0c
--- /dev/null
+++ b/dev-ml/utop/utop-2.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune elisp-common
+
+DESCRIPTION="Universal toplevel for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/utop"
+SRC_URI="https://github.com/ocaml-community/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs +ocamlopt"
+
+ELISP_DEPEND="
+ emacs? (
+ >=app-editors/emacs-24:*
+ >=app-emacs/tuareg-mode-2.2.0
+ )
+"
+DEPEND="
+ dev-ml/camomile:=
+ dev-ml/lambda-term:=
+ dev-ml/lwt:=
+ dev-ml/react:=
+"
+RDEPEND="
+ ${DEPEND}
+ ${ELISP_DEPEND}
+"
+BDEPEND="
+ dev-ml/cppo
+ dev-ml/findlib
+ ${ELISP_DEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ dune_src_compile
+
+ use emacs &&
+ BYTECOMPFLAGS="-L src/top" elisp-compile src/top/*.el
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} src/top/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}