summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-08 15:58:25 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-08 15:59:16 +0100
commitf9d8377083127c3b03dc0d18433f6b1761ff4e27 (patch)
tree336705a00f15870b366a4d0ea67fcb0ffb08f886 /dev-ml/uutf/uutf-1.0.3.ebuild
parentsys-libs/glibc: Re-keyword 2.34-r10 (diff)
downloadgentoo-f9d8377083127c3b03dc0d18433f6b1761ff4e27.tar.gz
gentoo-f9d8377083127c3b03dc0d18433f6b1761ff4e27.tar.bz2
gentoo-f9d8377083127c3b03dc0d18433f6b1761ff4e27.zip
dev-ml/uutf: bump to 1.0.3
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/uutf/uutf-1.0.3.ebuild')
-rw-r--r--dev-ml/uutf/uutf-1.0.3.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-ml/uutf/uutf-1.0.3.ebuild b/dev-ml/uutf/uutf-1.0.3.ebuild
new file mode 100644
index 000000000000..6f553e6fb98e
--- /dev/null
+++ b/dev-ml/uutf/uutf-1.0.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming Unicode codec for OCaml"
+HOMEPAGE="https://erratique.ch/software/uutf"
+SRC_URI="https://erratique.ch/software/uutf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc utftrip +ocamlopt test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="utftrip? ( ocamlopt )"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/uchar:=
+ utftrip? ( dev-ml/cmdliner:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/ocamlbuild
+ dev-ml/topkg
+ test? ( dev-ml/cmdliner )"
+
+DOCS=( CHANGES.md README.md )
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ --tests "$(usex test true false)" \
+ || die
+}
+
+src_test() {
+ if use ocamlopt ; then
+ pushd _build/test || die
+ ./test.native || die
+ # Rebuild to avoid mismatches between installed files, bug #604674
+ popd || die
+ ocaml pkg/pkg.ml build \
+ --with-cmdliner "$(usex utftrip true false)" \
+ || die
+ else
+ ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
+ fi
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+
+ use ocamlopt &&
+ nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
+ ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+ use utftrip &&
+ newbin _build/test/utftrip.$(usex ocamlopt native byte) utftrip
+
+ einstalldocs
+ if use doc ; then
+ docinto html
+ dodoc -r doc/*
+ fi
+}