summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-28 03:21:08 +0100
committerSam James <sam@gentoo.org>2021-07-28 03:21:08 +0100
commitb742968b4bb0638a375e507a6aaea3600eca1317 (patch)
treee7140bcae0e4f9515103ece277b060f587376e05 /dev-ml
parentdev-ml/opam-installer: add 2.0.9 (diff)
downloadgentoo-b742968b4bb0638a375e507a6aaea3600eca1317.tar.gz
gentoo-b742968b4bb0638a375e507a6aaea3600eca1317.tar.bz2
gentoo-b742968b4bb0638a375e507a6aaea3600eca1317.zip
dev-ml/opam-repository: add 2.0.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-repository/Manifest1
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/Manifest b/dev-ml/opam-repository/Manifest
index 6022b2986d90..a8c97c7a26f1 100644
--- a/dev-ml/opam-repository/Manifest
+++ b/dev-ml/opam-repository/Manifest
@@ -1 +1,2 @@
DIST opam-2.0.8.tar.gz 643221 BLAKE2B 66510a18285f315fe95665e8ba2f334dd44211c716543cdc25f2951a7dfe537f115981046e5963fd08deea4c76f5672fa7cf8e7af2274a713a3165bdd0bac8c2 SHA512 14737dc994be2c54dfeaf2658d3713178033e1bc2b4b845a58b4bfc118bbbf12b502924add0ae32b4b2b6c1944462e5ee7143df3de362d9ee39573249d013bc9
+DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e513736a27904a4e471d1eaf432db72998251ac786cb8fbf1ad425fff42b772c5d26934e0929aae75c0946d4659 SHA512 0d8ee19ac0f3df9de4fd9cfa8daab1f7228f090f5e2e7e26bedf24d8c2ab377aade95048f2d7cd9ee9dbbe738729e26dc99f41f730fa2252df74953362464a22
diff --git a/dev-ml/opam-repository/opam-repository-2.0.9.ebuild b/dev-ml/opam-repository/opam-repository-2.0.9.ebuild
new file mode 100644
index 000000000000..77365ae1bced
--- /dev/null
+++ b/dev-ml/opam-repository/opam-repository-2.0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam repository libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=
+ dev-ml/re:=
+ >=dev-ml/dose3-6.0:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}