summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-05-04 00:44:59 +1200
committerKent Fredric <kentnl@gentoo.org>2020-05-04 02:49:17 +1200
commit49f28dfc95b13f9127d8d2510596b96ff9f8ea4a (patch)
tree2d07aecc12bffb17503066c109e8286d1a834c95 /dev-perl/Config-MVP-Slicer/Config-MVP-Slicer-0.303.0.ebuild
parentdev-perl/Dist-Zilla-Plugin-VersionFromMainModule: Add w/v=0.40.0 (diff)
downloadgentoo-49f28dfc95b13f9127d8d2510596b96ff9f8ea4a.tar.gz
gentoo-49f28dfc95b13f9127d8d2510596b96ff9f8ea4a.tar.bz2
gentoo-49f28dfc95b13f9127d8d2510596b96ff9f8ea4a.zip
dev-perl/Config-MVP-Slicer: Add w/v=0.303.0
Required by: - dev-perl/Dist-Zilla-Config-Slicer - via dev-perl/Dist-Milla - via dev-perl/App-cpanminus (git sources) Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Config-MVP-Slicer/Config-MVP-Slicer-0.303.0.ebuild')
-rw-r--r--dev-perl/Config-MVP-Slicer/Config-MVP-Slicer-0.303.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Config-MVP-Slicer/Config-MVP-Slicer-0.303.0.ebuild b/dev-perl/Config-MVP-Slicer/Config-MVP-Slicer-0.303.0.ebuild
new file mode 100644
index 000000000000..0a4fb84cc321
--- /dev/null
+++ b/dev-perl/Config-MVP-Slicer/Config-MVP-Slicer-0.303.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RWSTAUNER
+DIST_VERSION=0.303
+inherit perl-module
+
+DESCRIPTION="Extract embedded plugin config from parent config"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Moose
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"