summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-10-31 09:41:35 -0400
committerBrian Evans <grknight@gentoo.org>2018-10-31 09:43:25 -0400
commit258f5a6fc07808616203b41cef8fb167e2d57251 (patch)
tree9f76afab18cfe58b60f825a4666d23c6bbecb0a0 /dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
parentdev-php/PEAR-Net_IPv6: Drop old (diff)
downloadgentoo-258f5a6fc07808616203b41cef8fb167e2d57251.tar.gz
gentoo-258f5a6fc07808616203b41cef8fb167e2d57251.tar.bz2
gentoo-258f5a6fc07808616203b41cef8fb167e2d57251.zip
dev-php/PEAR-Console_Table: Version bump for 1.3.1
Add test function as well Signed-off-by: Brian Evans <grknight@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild')
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
new file mode 100644
index 000000000000..b49bca76c897
--- /dev/null
+++ b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+DESCRIPTION="Class that makes it easy to build console style tables"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+BDEPEND="test? ( dev-php/pear )"
+
+src_install() {
+ insinto /usr/share/php/Console
+ doins Table.php
+ php-pear-r2_install_packagexml
+}
+
+src_test() {
+ pear run-tests tests || die "Tests failed"
+}