summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild')
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
new file mode 100644
index 000000000000..b49bca76c897
--- /dev/null
+++ b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+DESCRIPTION="Class that makes it easy to build console style tables"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+BDEPEND="test? ( dev-php/pear )"
+
+src_install() {
+ insinto /usr/share/php/Console
+ doins Table.php
+ php-pear-r2_install_packagexml
+}
+
+src_test() {
+ pear run-tests tests || die "Tests failed"
+}