summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-03-22 08:57:14 -0400
committerBrian Evans <grknight@gentoo.org>2021-03-22 08:57:14 -0400
commit353d2a156672c94d63678eb7523cdc766897fa8c (patch)
treeb1d8e9b53fb21e2ca06e75f180ffa660f48f6ebd /dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
parentapp-text/xchm: bump to 1.32 (diff)
downloadgentoo-353d2a156672c94d63678eb7523cdc766897fa8c.tar.gz
gentoo-353d2a156672c94d63678eb7523cdc766897fa8c.tar.bz2
gentoo-353d2a156672c94d63678eb7523cdc766897fa8c.zip
dev-php/PEAR-Exception: Version bump for 1.0.2
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild')
-rw-r--r--dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild b/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
new file mode 100644
index 000000000000..2a4a155c793d
--- /dev/null
+++ b/dev-php/PEAR-Exception/PEAR-Exception-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The PEAR Exception base class"
+HOMEPAGE="https://pear.php.net/package/PEAR_Exception"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-lang/php:*
+ !<=dev-php/PEAR-PEAR-1.10.3-r1"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r PEAR
+}
+
+src_test() {
+ phpunit --do-not-cache-result tests || die "test suite failed"
+}