summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-19 22:54:15 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-19 22:54:55 +0100
commitb4a7dfdb50525cca2779f081910d4ed8df6e689c (patch)
tree0a2db4529bb1acbf4ed4220809aa6818af31fa78 /dev-php
parentdev-php/symfony-process: bump to v3.4.38 (diff)
downloadgentoo-b4a7dfdb50525cca2779f081910d4ed8df6e689c.tar.gz
gentoo-b4a7dfdb50525cca2779f081910d4ed8df6e689c.tar.bz2
gentoo-b4a7dfdb50525cca2779f081910d4ed8df6e689c.zip
dev-php/xdebug-handler: bump to v1.4.1
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xdebug-handler/Manifest1
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/Manifest b/dev-php/xdebug-handler/Manifest
index fec61186707f..2ea6a104365d 100644
--- a/dev-php/xdebug-handler/Manifest
+++ b/dev-php/xdebug-handler/Manifest
@@ -1,2 +1,3 @@
DIST xdebug-handler-1.3.0.tar.gz 12363 BLAKE2B ad89580e57728a444958d72f236fee14665f6fbed998018a28b181cdfc3a448da0a06dc335c3d95413eff6f6b92fc3d44ac8c03da282eb3dc65ae14600430825 SHA512 ed0206982c5ffab3c8ff56dcf8055230aaa358fbe89c15880cfce33abc27adb3b13f75bf7d78988f6bae4d0d072c66f557cd93082e89e7ca7993b257c04a2c61
DIST xdebug-handler-1.3.1.tar.gz 12589 BLAKE2B fcee0a2412473f5e7a07defa96b991803728f831c8ab0dfa053c3ff8671a2dd187d5199e51ac90579830f5a005038411c2097be8a1f1370e8e06d090922f508a SHA512 a00d9cb8e23cd6bbad6c25f82c8db314451a88f49d90e755a9c81fa57794ecc79612481e031d60cdb2ee4fd4e256ffc02e847c76089daf720f8811659799131e
+DIST xdebug-handler-1.4.1.tar.gz 13190 BLAKE2B 05637bbe52896f779026258e5b69d6fae03d575e8a497ea983fe67354af6277a7769ec32ce3c10682ce2f654c135086710836005561211b04958546180228d50 SHA512 ac79debf0cb6a31f90354115b6fda1d373b148691dd0b86044ae7a257f2fc6998a773e1b150519d12e6dcbeddf326ed38f9b8fbdc0dec736ebfc4cc6e83a462d
diff --git a/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
new file mode 100644
index 000000000000..806a747fbd38
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="https://github.com/composer/xdebug-handler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}