summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-17 00:22:27 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-17 00:48:15 -0400
commitcbc14347484f0a9921d2498235115e61f8d594ea (patch)
tree4b6c57d5f15bab4ef128c2e466a789fec3f4fa7b /dev-python/PyQt6/PyQt6-6.5.1.ebuild
parentdev-python/PyQt6: drop 6.5.0 (diff)
downloadgentoo-cbc14347484f0a9921d2498235115e61f8d594ea.tar.gz
gentoo-cbc14347484f0a9921d2498235115e61f8d594ea.tar.bz2
gentoo-cbc14347484f0a9921d2498235115e61f8d594ea.zip
dev-python/PyQt6: remove gcc dependency, update hack
Turns out that this *can* use clang++ but only if qtbase was built with clang++ as well, otherwise it still uses g++ even with CXX=clang++ But given the former, there is little reason to enforce the dependency. Ideally would use CXX but that would require more elaborate testing to know what it is and what qtbase was built with (perhaps if ever add the hack to qmake-utils.eclass). No revbump given PyQt* bindings are a slowish build and depcleaning gcc is a bit niche, the few interested can handle this manually until next bump. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6/PyQt6-6.5.1.ebuild')
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.5.1.ebuild b/dev-python/PyQt6/PyQt6-6.5.1.ebuild
index dcf60aee78e0..29f6a8ef6fe2 100644
--- a/dev-python/PyQt6/PyQt6-6.5.1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.1.ebuild
@@ -66,16 +66,18 @@ RDEPEND="
BDEPEND="
>=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
>=dev-qt/qtbase-${QT_PV}
- sys-devel/gcc
dbus? ( virtual/pkgconfig )"
src_prepare() {
default
- # hack: qmake queries g++ directly for info (not building) and that doesn't
- # work with clang, this is to make it at least respect CHOST (bug #726112)
+ # hack: qmake queries g++ or clang++ for info depending on which qtbase was
+ # built with, but ignores CHOST failing with -native-symlinks (bug #726112)
+ # and potentially using wrong information when cross-compiling
mkdir "${T}"/cxx || die
- ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
+ local cxx
+ ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
+ ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
PATH=${T}/cxx:${PATH}
}