summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6/PyQt6-6.5.1.ebuild')
-rw-r--r--dev-python/PyQt6/PyQt6-6.5.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/PyQt6/PyQt6-6.5.1.ebuild b/dev-python/PyQt6/PyQt6-6.5.1.ebuild
index dcf60aee78e0..29f6a8ef6fe2 100644
--- a/dev-python/PyQt6/PyQt6-6.5.1.ebuild
+++ b/dev-python/PyQt6/PyQt6-6.5.1.ebuild
@@ -66,16 +66,18 @@ RDEPEND="
BDEPEND="
>=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
>=dev-qt/qtbase-${QT_PV}
- sys-devel/gcc
dbus? ( virtual/pkgconfig )"
src_prepare() {
default
- # hack: qmake queries g++ directly for info (not building) and that doesn't
- # work with clang, this is to make it at least respect CHOST (bug #726112)
+ # hack: qmake queries g++ or clang++ for info depending on which qtbase was
+ # built with, but ignores CHOST failing with -native-symlinks (bug #726112)
+ # and potentially using wrong information when cross-compiling
mkdir "${T}"/cxx || die
- ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
+ local cxx
+ ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
+ ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
PATH=${T}/cxx:${PATH}
}