summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-09-18 16:35:52 -0700
committerZac Medico <zmedico@gentoo.org>2016-09-18 16:38:14 -0700
commitecba64766321bfe2309a363021336adfb72157c2 (patch)
treec32f2df55cd754088872e4c2e76aea85c9a3e9bf /dev-python/aiodns/aiodns-1.1.1.ebuild
parentprofiles: remove stale chromium masks (diff)
downloadgentoo-ecba64766321bfe2309a363021336adfb72157c2.tar.gz
gentoo-ecba64766321bfe2309a363021336adfb72157c2.tar.bz2
gentoo-ecba64766321bfe2309a363021336adfb72157c2.zip
dev-python/aiodns: add package (bug 533584)
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/aiodns/aiodns-1.1.1.ebuild')
-rw-r--r--dev-python/aiodns/aiodns-1.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/aiodns/aiodns-1.1.1.ebuild b/dev-python/aiodns/aiodns-1.1.1.ebuild
new file mode 100644
index 000000000000..9cfa55ca4a6b
--- /dev/null
+++ b/dev-python/aiodns/aiodns-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/trollius[python_targets_python2_7]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON:-python}" tests.py || die
+}