summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 12:29:58 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-20 12:48:45 +0200
commit07bb7b8a7d09e799c5cacde586759269cc838ecd (patch)
tree29ba10c2712f127a01a81ac22fc0a1e8c96f66ef /dev-python/aiotest/aiotest-0.3.ebuild
parentwww-apps/owncloud: maintenance release bumps (diff)
downloadgentoo-07bb7b8a7d09e799c5cacde586759269cc838ecd.tar.gz
gentoo-07bb7b8a7d09e799c5cacde586759269cc838ecd.tar.bz2
gentoo-07bb7b8a7d09e799c5cacde586759269cc838ecd.zip
dev-python/aiotest: Add package needed for aioeventlet tests
Diffstat (limited to 'dev-python/aiotest/aiotest-0.3.ebuild')
-rw-r--r--dev-python/aiotest/aiotest-0.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/aiotest/aiotest-0.3.ebuild b/dev-python/aiotest/aiotest-0.3.ebuild
new file mode 100644
index 000000000000..3ffcc8bb8bac
--- /dev/null
+++ b/dev-python/aiotest/aiotest-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Test suite for an implementation of asyncio (PEP 3156)"
+HOMEPAGE="https://bitbucket.org/haypo/aiotest"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local suite
+ python_is_python3 && suite=asyncio || suite=trollius
+ "${PYTHON}" "test_${suite}.py" || die "Tests fail with ${EPYHON} (${suite})"
+}