summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-24 08:19:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-24 08:41:07 +0100
commit0df03eddf3da922d961369666560a47c7abe7046 (patch)
tree488c0123fce40296f20ea42b184ce2b8ddcaea1c /dev-python/alembic/alembic-1.9.1.ebuild
parentdev-libs/libretls: Bump to 3.7.0 (diff)
downloadgentoo-0df03eddf3da922d961369666560a47c7abe7046.tar.gz
gentoo-0df03eddf3da922d961369666560a47c7abe7046.tar.bz2
gentoo-0df03eddf3da922d961369666560a47c7abe7046.zip
dev-python/alembic: Bump to 1.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic/alembic-1.9.1.ebuild')
-rw-r--r--dev-python/alembic/alembic-1.9.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-1.9.1.ebuild b/dev-python/alembic/alembic-1.9.1.ebuild
new file mode 100644
index 000000000000..be24ef80d028
--- /dev/null
+++ b/dev-python/alembic/alembic-1.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}