summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-21 20:39:07 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-21 20:43:23 +0100
commitfa7891a09a3f4798acee244620a98d81bb730592 (patch)
tree9ebce83e157573c1f0b0ccd96fb4ddbac45c86e7 /dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
parentnet-fs/samba: stable 4.5.15 for sparc, bug #639024 (diff)
downloadgentoo-fa7891a09a3f4798acee244620a98d81bb730592.tar.gz
gentoo-fa7891a09a3f4798acee244620a98d81bb730592.tar.bz2
gentoo-fa7891a09a3f4798acee244620a98d81bb730592.zip
dev-python/asn1crypto: Bump to 0.24.0, use gh tarball for tests
Diffstat (limited to 'dev-python/asn1crypto/asn1crypto-0.24.0.ebuild')
-rw-r--r--dev-python/asn1crypto/asn1crypto-0.24.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild b/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
new file mode 100644
index 000000000000..b84c9f3f19d3
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.python.org/pypi/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x64-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}