summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-10-21 21:59:27 -0500
committerMichał Górny <mgorny@gentoo.org>2018-11-28 11:03:57 +0100
commita8d045f19b6bf76f46c7120d3a2462c068c5bb72 (patch)
tree5219b6287358c34fbbd8028708ebf987e8bec533 /dev-python/asynctest/asynctest-0.12.2.ebuild
parentuse.desc: Remove now-local-only flags (diff)
downloadgentoo-a8d045f19b6bf76f46c7120d3a2462c068c5bb72.tar.gz
gentoo-a8d045f19b6bf76f46c7120d3a2462c068c5bb72.tar.bz2
gentoo-a8d045f19b6bf76f46c7120d3a2462c068c5bb72.zip
dev-python/asynctest: Introducing new package
Introducing the latest available version of the package. Closes: https://bugs.gentoo.org/669272 Signed-off-by: Oleksandr Trotsenko <oleksandr.trotsenko@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10196 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asynctest/asynctest-0.12.2.ebuild')
-rw-r--r--dev-python/asynctest/asynctest-0.12.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/asynctest/asynctest-0.12.2.ebuild b/dev-python/asynctest/asynctest-0.12.2.ebuild
new file mode 100644
index 000000000000..9ce7712a4051
--- /dev/null
+++ b/dev-python/asynctest/asynctest-0.12.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Enhance the standard unittest with features for testing asyncio libraries"
+HOMEPAGE="https://github.com/Martiusweb/asynctest/ https://pypi.org/project/asynctest/"
+SRC_URI="https://github.com/Martiusweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ default
+
+ sed -i "{s/test_events_watched_outside_test_are_ignored/_&/}" "test/test_selector.py" || die "Could not disable the failing test."
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest -v test || die "Testing failed"
+}