summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-15 09:51:07 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-15 09:59:55 +0100
commitacd8acd5b409a505ca13a39169dbce7ad1ae3f80 (patch)
treea8aed811e7e8d95045b4db99b30ebbd0ff7678b4 /dev-python/attrs/attrs-19.3.0.ebuild
parentapp-emacs/sokoban: amd64/x86 stable, (ALLARCHES policy) wrt bug #700074 (diff)
downloadgentoo-acd8acd5b409a505ca13a39169dbce7ad1ae3f80.tar.gz
gentoo-acd8acd5b409a505ca13a39169dbce7ad1ae3f80.tar.bz2
gentoo-acd8acd5b409a505ca13a39169dbce7ad1ae3f80.zip
dev-python/attrs: Bump to 19.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/attrs/attrs-19.3.0.ebuild')
-rw-r--r--dev-python/attrs/attrs-19.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/attrs/attrs-19.3.0.ebuild b/dev-python/attrs/attrs-19.3.0.ebuild
new file mode 100644
index 000000000000..a36ceb872a19
--- /dev/null
+++ b/dev-python/attrs/attrs-19.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/hynek/attrs
+ https://attrs.readthedocs.org/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest