summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-11-25 13:03:21 +0200
committerMichał Górny <mgorny@gentoo.org>2019-11-29 20:54:28 +0100
commit87f6122ad218de0482309d3b840e221fa8d74334 (patch)
tree0709a0f60aa8db94270f188307f836519a4fa708 /dev-python/autopep8
parentdev-python/autopep8: bump v1.4.4 (diff)
downloadgentoo-87f6122ad218de0482309d3b840e221fa8d74334.tar.gz
gentoo-87f6122ad218de0482309d3b840e221fa8d74334.tar.bz2
gentoo-87f6122ad218de0482309d3b840e221fa8d74334.zip
dev-python/autopep8: update live version
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild17
1 files changed, 6 insertions, 11 deletions
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index 18e92a67fb4f..ae057e4cf2d2 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6}} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -20,14 +20,9 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="test"
-RDEPEND="
- >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
-python_test() {
- "${PYTHON}" setup.py test || die
-}
+distutils_enable_tests setup.py