summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-07 20:40:02 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-10 05:26:39 +0000
commit58118496647918450a1cb053f309c178c6577aae (patch)
tree4a3ca031602218c6745a26c3392f80ac45194014 /dev-python/blosc/blosc-1.4.4.ebuild
parentdev-python/multipledispatch: version bump (diff)
downloadgentoo-58118496647918450a1cb053f309c178c6577aae.tar.gz
gentoo-58118496647918450a1cb053f309c178c6577aae.tar.bz2
gentoo-58118496647918450a1cb053f309c178c6577aae.zip
dev-python/blosc: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/blosc/blosc-1.4.4.ebuild')
-rw-r--r--dev-python/blosc/blosc-1.4.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/blosc/blosc-1.4.4.ebuild b/dev-python/blosc/blosc-1.4.4.ebuild
new file mode 100644
index 000000000000..de81068d2b94
--- /dev/null
+++ b/dev-python/blosc/blosc-1.4.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance compressor optimized for binary data"
+HOMEPAGE="http://python-blosc.blosc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-libs/c-blosc:="
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ export BLOSC_DIR="${EPREFIX}/usr"
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ nosetests -v || die
+}