summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-22 11:58:27 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-22 11:58:36 +0100
commitb5d930d9acd29d3b001500848db94891191db4df (patch)
tree6c58cbb0d35199add31d224bc9337fc5830a7491 /dev-python/boto
parentMerge remote-tracking branch 'remotes/github/pr/701' (diff)
downloadgentoo-b5d930d9acd29d3b001500848db94891191db4df.tar.gz
gentoo-b5d930d9acd29d3b001500848db94891191db4df.tar.bz2
gentoo-b5d930d9acd29d3b001500848db94891191db4df.zip
dev-python/boto: Build docs using python2.7
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=572540 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/boto')
-rw-r--r--dev-python/boto/boto-2.39.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/boto/boto-2.39.0.ebuild b/dev-python/boto/boto-2.39.0.ebuild
index 09e8e9d3272a..532f9359b21a 100644
--- a/dev-python/boto/boto-2.39.0.ebuild
+++ b/dev-python/boto/boto-2.39.0.ebuild
@@ -17,6 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc test"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
@@ -25,6 +27,10 @@ DEPEND="
# requires Amazon Web Services keys to pass some tests
RESTRICT="test"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_test() {
"${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
}