summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-10-12 21:06:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2016-10-12 21:06:04 +0700
commitae9cf0227e5181ae09019ba9914803463bb22f4e (patch)
tree2c84c90b65397e4a9bf76b7084b5eff1e02fab8b /dev-python/bpython/bpython-0.16.ebuild
parentdev-python/curtsies: cleaning old (diff)
downloadgentoo-ae9cf0227e5181ae09019ba9914803463bb22f4e.tar.gz
gentoo-ae9cf0227e5181ae09019ba9914803463bb22f4e.tar.bz2
gentoo-ae9cf0227e5181ae09019ba9914803463bb22f4e.zip
dev-python/bpython: bump to 0.16
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/bpython/bpython-0.16.ebuild')
-rw-r--r--dev-python/bpython/bpython-0.16.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/bpython/bpython-0.16.ebuild b/dev-python/bpython/bpython-0.16.ebuild
new file mode 100644
index 000000000000..3b5ac833b523
--- /dev/null
+++ b/dev-python/bpython/bpython-0.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.python.org/pypi/bpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/curtsies-0.2.10[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+# Req'd for clean build by each impl
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/sphinx/source/ \
+ doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
+ fi
+}
+
+python_test() {
+ pushd build/lib > /dev/null
+ "${PYTHON}" -m unittest discover || die
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
+ distutils-r1_python_install_all
+}