summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-03-30 15:06:28 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-03-30 15:06:42 -0700
commit3ffcde8c1e7685008918495dfa152afa132573eb (patch)
tree4b8ad5738638918e423d12971f1e1096e5f8df36 /dev-python/cherrypy
parentnet-print/hplip-plugin: Version bump to 3.20.2 (diff)
downloadgentoo-3ffcde8c1e7685008918495dfa152afa132573eb.tar.gz
gentoo-3ffcde8c1e7685008918495dfa152afa132573eb.tar.bz2
gentoo-3ffcde8c1e7685008918495dfa152afa132573eb.zip
dev-python/cherrypy: Fix sed to remove pytest-cov
We need to make sure all pytest-cov related parameters are stripped, not just the first one. Bug: https://bugs.gentoo.org/715008 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/cherrypy-18.5.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/cherrypy/cherrypy-18.5.0.ebuild b/dev-python/cherrypy/cherrypy-18.5.0.ebuild
index d113700efc16..2e86a61b6462 100644
--- a/dev-python/cherrypy/cherrypy-18.5.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-18.5.0.ebuild
@@ -53,9 +53,9 @@ python_prepare_all() {
sed -r -e '/(pytest-sugar|pytest-cov)/ d' \
-i setup.py || die
- sed -r -e 's:--cov-report[[:space:]]+[[:graph:]]+::' \
- -e 's:--cov[[:graph:]]+::' \
- -e 's:--doctest[[:graph:]]+::' \
+ sed -r -e 's:--cov-report[[:space:]]+[[:graph:]]+::g' \
+ -e 's:--cov[[:graph:]]+::g' \
+ -e 's:--doctest[[:graph:]]+::g' \
-i pytest.ini || die
distutils-r1_python_prepare_all