summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-17 18:11:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-17 18:11:08 +0100
commit8e6f391d59f59212c60bd407018daf7baea14370 (patch)
treecb5b06f883bb645b8d7f141ef2236c261a2bad5a /dev-python/coloredlogs/coloredlogs-5.0.ebuild
parentdev-python/coloredlogs: Drop old (diff)
downloadgentoo-8e6f391d59f59212c60bd407018daf7baea14370.tar.gz
gentoo-8e6f391d59f59212c60bd407018daf7baea14370.tar.bz2
gentoo-8e6f391d59f59212c60bd407018daf7baea14370.zip
dev-python/coloredlogs: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/coloredlogs/coloredlogs-5.0.ebuild')
-rw-r--r--dev-python/coloredlogs/coloredlogs-5.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/coloredlogs-5.0.ebuild b/dev-python/coloredlogs/coloredlogs-5.0.ebuild
new file mode 100644
index 000000000000..ec7bcb061bc0
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="https://pypi.python.org/pypi/coloredlogs https://github.com/xolox/python-coloredlogs http://coloredlogs.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/humanfriendly-1.42[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( README.rst )
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-skip-cli-test.patch )
+
+python_test() {
+ # Sandbox violations
+ sed \
+ -e 's:test_system_logging:_&:g' \
+ -i ${PN}/tests.py || die
+ esetup.py test
+}