summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-28 18:29:50 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-28 19:03:18 +0200
commit3201627b559b469bc9d1f88140a08586a6f16384 (patch)
tree9f109bdd4cb58d6a3d0081cc53ad68520342877d /dev-python/coloredlogs/files
parentdev-python/capturer: bump to 3.0, add PyPy3+Py3.9 and doc (diff)
downloadgentoo-3201627b559b469bc9d1f88140a08586a6f16384.tar.gz
gentoo-3201627b559b469bc9d1f88140a08586a6f16384.tar.bz2
gentoo-3201627b559b469bc9d1f88140a08586a6f16384.zip
dev-python/coloredlogs: bump to 14.0, add PyPy3+Python 3.9 support
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/coloredlogs/files')
-rw-r--r--dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch b/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch
new file mode 100644
index 000000000000..d6b60c3bdf57
--- /dev/null
+++ b/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch
@@ -0,0 +1,35 @@
+commit 6f566c799323feb3b8dc2b82e62953040a6a5129
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Sat Sep 26 10:30:37 2020 +0200
+
+ setup.py: use absolute paths for pth files
+
+ On some systems (such as PyPy3 on Gentoo), distutils' `data` path is not
+ `sys.prefix`, which means that we cannot rely on relative paths.
+
+diff --git a/setup.py b/setup.py
+index 057dd80..7674adc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -66,9 +66,9 @@ def find_pth_directory():
+ Determine the correct directory pathname for installing ``*.pth`` files.
+
+ To install a ``*.pth`` file using a source distribution archive (created
+- when ``python setup.py sdist`` is called) the relative directory pathname
+- ``lib/pythonX.Y/site-packages`` needs to be passed to the ``data_files``
+- option to ``setup()``.
++ when ``python setup.py sdist`` is called) the directory pathname
++ ``/usr/lib/pythonX.Y/site-packages`` needs to be passed to the ``data_files``
++ option of ``setup()``.
+
+ Unfortunately this breaks universal wheel archives (created when ``python
+ setup.py bdist_wheel --universal`` is called) because a specific Python
+@@ -81,7 +81,7 @@ def find_pth_directory():
+ directory without hard coding its location.
+ """
+ return ('/' if 'bdist_wheel' in sys.argv
+- else os.path.relpath(distutils.sysconfig.get_python_lib(), sys.prefix))
++ else distutils.sysconfig.get_python_lib())
+
+
+ setup(name='coloredlogs',