summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-28 18:29:50 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-28 19:03:18 +0200
commit3201627b559b469bc9d1f88140a08586a6f16384 (patch)
tree9f109bdd4cb58d6a3d0081cc53ad68520342877d /dev-python
parentdev-python/capturer: bump to 3.0, add PyPy3+Py3.9 and doc (diff)
downloadgentoo-3201627b559b469bc9d1f88140a08586a6f16384.tar.gz
gentoo-3201627b559b469bc9d1f88140a08586a6f16384.tar.bz2
gentoo-3201627b559b469bc9d1f88140a08586a6f16384.zip
dev-python/coloredlogs: bump to 14.0, add PyPy3+Python 3.9 support
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/coloredlogs/Manifest1
-rw-r--r--dev-python/coloredlogs/coloredlogs-14.0.ebuild46
-rw-r--r--dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch35
3 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/Manifest b/dev-python/coloredlogs/Manifest
index ed2a550127e3..7e04c31b3a25 100644
--- a/dev-python/coloredlogs/Manifest
+++ b/dev-python/coloredlogs/Manifest
@@ -1 +1,2 @@
DIST coloredlogs-10.0.tar.gz 273273 BLAKE2B 775b12718d780da396d74c7f960cdbbd4858c793bf3eefb53d29e9f6b415f682110ae2c7ac631be230578946a2fab8d75e0c3aa487ccd952bb05443f0a85700c SHA512 f4a51fd8fa92ea4e2ef0b58305dcc4bbe12851e722fc85cfd4f48a9388002efced52bcf027f6dc4c525b095f3f953970e73928fdce3245ab4f9d13ae36b9d498
+DIST coloredlogs-14.0.tar.gz 275863 BLAKE2B 0a8c026220955397378ad2b43a69c89c5710a09e2d9ed81a3f25408c60e171f4b8f78239696a0bc1b51fc3dd9bfca80df63e1f1d7afb6bee0046209a089e0d6d SHA512 3434a95f3216d19af5d7a48324e5afd5e975f92d9f6b99f40df2c0a635f1738e0bc6d7277a549a42a0fec5a8601f82908c4b0205ceeb3666f49210f66fe58671
diff --git a/dev-python/coloredlogs/coloredlogs-14.0.ebuild b/dev-python/coloredlogs/coloredlogs-14.0.ebuild
new file mode 100644
index 000000000000..89c3d911e9f4
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-14.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="
+ https://pypi.org/project/coloredlogs/
+ https://github.com/xolox/python-coloredlogs
+ https://coloredlogs.readthedocs.io/en/latest/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-install-prefix.patch" )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # test_cli_conversion requires the package to be installed
+ distutils_install_for_testing
+ # test_auto_install fails because the pth file isn't being loaded
+ pytest -vv ${PN}/tests.py \
+ --deselect ${PN}/tests.py::ColoredLogsTestCase::test_auto_install \
+ || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch b/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch
new file mode 100644
index 000000000000..d6b60c3bdf57
--- /dev/null
+++ b/dev-python/coloredlogs/files/coloredlogs-14.0-fix-install-prefix.patch
@@ -0,0 +1,35 @@
+commit 6f566c799323feb3b8dc2b82e62953040a6a5129
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Sat Sep 26 10:30:37 2020 +0200
+
+ setup.py: use absolute paths for pth files
+
+ On some systems (such as PyPy3 on Gentoo), distutils' `data` path is not
+ `sys.prefix`, which means that we cannot rely on relative paths.
+
+diff --git a/setup.py b/setup.py
+index 057dd80..7674adc 100755
+--- a/setup.py
++++ b/setup.py
+@@ -66,9 +66,9 @@ def find_pth_directory():
+ Determine the correct directory pathname for installing ``*.pth`` files.
+
+ To install a ``*.pth`` file using a source distribution archive (created
+- when ``python setup.py sdist`` is called) the relative directory pathname
+- ``lib/pythonX.Y/site-packages`` needs to be passed to the ``data_files``
+- option to ``setup()``.
++ when ``python setup.py sdist`` is called) the directory pathname
++ ``/usr/lib/pythonX.Y/site-packages`` needs to be passed to the ``data_files``
++ option of ``setup()``.
+
+ Unfortunately this breaks universal wheel archives (created when ``python
+ setup.py bdist_wheel --universal`` is called) because a specific Python
+@@ -81,7 +81,7 @@ def find_pth_directory():
+ directory without hard coding its location.
+ """
+ return ('/' if 'bdist_wheel' in sys.argv
+- else os.path.relpath(distutils.sysconfig.get_python_lib(), sys.prefix))
++ else distutils.sysconfig.get_python_lib())
+
+
+ setup(name='coloredlogs',