summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-06-28 13:20:21 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-06-28 13:23:51 -0500
commit923fee9b310202c0690758bc64b4d275236d83cd (patch)
tree374248da6c8e61f25a0c386813e65514b25794da /dev-python/coreapi
parentdev-libs/flatbuffers: Drop 1.10.0 (diff)
downloadgentoo-923fee9b310202c0690758bc64b4d275236d83cd.tar.gz
gentoo-923fee9b310202c0690758bc64b4d275236d83cd.tar.bz2
gentoo-923fee9b310202c0690758bc64b4d275236d83cd.zip
dev-python/coreapi: 2.3.3-r1 bump to add missing dependencies
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/coreapi')
-rw-r--r--dev-python/coreapi/coreapi-2.3.3-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/coreapi/coreapi-2.3.3-r1.ebuild b/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..54c411dd20d8
--- /dev/null
+++ b/dev-python/coreapi/coreapi-2.3.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for Core API"
+HOMEPAGE="https://github.com/core-api/python-client"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/itypes[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"