summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-06 17:53:41 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-06 17:53:41 -0800
commitcb18007c355a53bc442b1fec1ab5360753a339e8 (patch)
treed073de88299bacab63ef567c7a9e468777279294 /dev-python/ddt/ddt-1.2.2.ebuild
parentapp-misc/rioutil: rework libdir path (diff)
downloadgentoo-cb18007c355a53bc442b1fec1ab5360753a339e8.tar.gz
gentoo-cb18007c355a53bc442b1fec1ab5360753a339e8.tar.bz2
gentoo-cb18007c355a53bc442b1fec1ab5360753a339e8.zip
dev-python/ddt-1.2.2: Version bump, add py38 and pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ddt/ddt-1.2.2.ebuild')
-rw-r--r--dev-python/ddt/ddt-1.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ddt/ddt-1.2.2.ebuild b/dev-python/ddt/ddt-1.2.2.ebuild
new file mode 100644
index 000000000000..b3e404bebdea
--- /dev/null
+++ b/dev-python/ddt/ddt-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to multiply test cases"
+HOMEPAGE="https://pypi.org/project/ddt/ https://github.com/txels/ddt"
+SRC_URI="https://github.com/datadriventests/ddt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose