summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-18 08:39:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-18 08:41:12 +0200
commitc326c77877c1c47516f5a15d9f4d6983eecf11c3 (patch)
tree03fef4761e6feca4cacbaf23cb30b145a45a7294 /dev-python/django-compressor/django-compressor-2.4.1.ebuild
parentnet-misc/youtube-dl: Remove old (diff)
downloadgentoo-c326c77877c1c47516f5a15d9f4d6983eecf11c3.tar.gz
gentoo-c326c77877c1c47516f5a15d9f4d6983eecf11c3.tar.bz2
gentoo-c326c77877c1c47516f5a15d9f4d6983eecf11c3.zip
dev-python/django-compressor: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-compressor/django-compressor-2.4.1.ebuild')
-rw-r--r--dev-python/django-compressor/django-compressor-2.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/django-compressor/django-compressor-2.4.1.ebuild b/dev-python/django-compressor/django-compressor-2.4.1.ebuild
new file mode 100644
index 000000000000..1d529ff01535
--- /dev/null
+++ b/dev-python/django-compressor/django-compressor-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Compresses linked and inline JavaScript or CSS into single cached files."
+HOMEPAGE="https://django-compressor.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+# missing test deps, package does not handle them gracefully, also seem
+# broken or whatever
+RESTRICT="test"
+
+RDEPEND="dev-python/django-appconf[${PYTHON_USEDEP}]
+ dev-python/rcssmin[${PYTHON_USEDEP}]
+ dev-python/rjsmin[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ django-admin.py test --settings=compressor.test_settings compressor ||
+ die "Tests failed with ${EPYTHON}"
+}