summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-08 10:42:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-08 10:47:16 +0200
commit255dc2a41e01e65c8e10dc31b1a7c775d686345a (patch)
tree34796fbb0a6bfcbbd3c45aca35e53149b2b71500 /dev-python/django-rq
parentdev-python/rq: Use PEP517 build (diff)
downloadgentoo-255dc2a41e01e65c8e10dc31b1a7c775d686345a.tar.gz
gentoo-255dc2a41e01e65c8e10dc31b1a7c775d686345a.tar.bz2
gentoo-255dc2a41e01e65c8e10dc31b1a7c775d686345a.zip
dev-python/django-rq: Remove py3.8 due to rq losing it
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-rq')
-rw-r--r--dev-python/django-rq/django-rq-2.4.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/django-rq/django-rq-2.4.1-r1.ebuild b/dev-python/django-rq/django-rq-2.4.1-r1.ebuild
new file mode 100644
index 000000000000..23ef26f48a02
--- /dev/null
+++ b/dev-python/django-rq/django-rq-2.4.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_9 )
+inherit distutils-r1
+
+DESCRIPTION="An app that provides django integration for RQ (Redis Queue)"
+HOMEPAGE="https://github.com/rq/django-rq/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.0[${PYTHON_USEDEP}]
+ >=dev-python/rq-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.0.0[${PYTHON_USEDEP}]
+"