summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-05-10 11:32:06 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-05-10 11:40:37 -0500
commit42fe76907a3b5802e2d9d1dc3afdee787d01ab61 (patch)
tree0b190f577b33536c06932de49a161946a8694959 /dev-python/dulwich/dulwich-0.17.3.ebuild
parentdev-python/geventhttpclient: adding python3_6 support (diff)
downloadgentoo-42fe76907a3b5802e2d9d1dc3afdee787d01ab61.tar.gz
gentoo-42fe76907a3b5802e2d9d1dc3afdee787d01ab61.tar.bz2
gentoo-42fe76907a3b5802e2d9d1dc3afdee787d01ab61.zip
dev-python/dulwich: bup
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/dulwich/dulwich-0.17.3.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.17.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/dulwich/dulwich-0.17.3.ebuild b/dev-python/dulwich/dulwich-0.17.3.ebuild
new file mode 100644
index 000000000000..739dfbb37b4e
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.17.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake check
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}