summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-07 10:07:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-07 10:47:04 +0200
commitde32052ea08a4dbde8c1ae6f6c38d2aee0414b69 (patch)
tree65e3b224169eacdc532f1bf9596c2591fe990592 /dev-python/exdown
parentlicenses: Add Brother for media-gfx/brscan4 (diff)
downloadgentoo-de32052ea08a4dbde8c1ae6f6c38d2aee0414b69.tar.gz
gentoo-de32052ea08a4dbde8c1ae6f6c38d2aee0414b69.tar.bz2
gentoo-de32052ea08a4dbde8c1ae6f6c38d2aee0414b69.zip
dev-python/exdown: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/exdown')
-rw-r--r--dev-python/exdown/Manifest1
-rw-r--r--dev-python/exdown/exdown-0.9.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/exdown/Manifest b/dev-python/exdown/Manifest
index 1eccde3c67cd..1f5deedebc9c 100644
--- a/dev-python/exdown/Manifest
+++ b/dev-python/exdown/Manifest
@@ -1,3 +1,4 @@
DIST exdown-0.8.6.tar.gz 5480 BLAKE2B fe383a2092691afdb2a3fd8cfeffb78f62b23bd4dc8f8d5365102084acc8670c9f2bc3e4a0ade95a50ceffc5cc142c39dbd3e505678a238d6f39b82f6553071a SHA512 28cd68ed99d24c79a7764f7603242f2b1426f119864d39424b1326cecc5bc922ed610133099e7d03d384c485f4f67d1fefcaadee4e1f69ac8ece08136eb858e9
DIST exdown-0.8.8.tar.gz 5523 BLAKE2B b53f23ebf133ad75973298b9b98c3f85f63802a9a302e92dda1446f0d686ba4eecd4fa72056d331b6e6caca5e066ec032a31fbfa3e74c1dba39ed007cf116480 SHA512 f5ef32b15720091c459110d6c9644b8dfcc84f6fd117f8433380704e93848cac0c9a3709d879bc42561474dd46b2035bc2be2f7e0bb5207a40ceb26ce4577b4a
DIST exdown-0.8.9.tar.gz 5558 BLAKE2B 9fade2918bed1a6f81619e2d2bf13a2459f36e73422e271fc470944006b2fb28d5fe0c7bd01810a605fdae64a3725d96e9ea3b8b39f391a4254292244437f380 SHA512 c1d556634295dc24fb7b4a13ea73aff9a162d96e5f698c3923e87fb6a5a1b28be49d2527d91b861aeb8c26bce08b8ebfa0ad6b02553d8e7c291430ec1f72be7c
+DIST pytest-codeblocks-0.9.0.tar.gz 6590 BLAKE2B 34d1c72a891d2f2f1d98c4238322d888a48b286d628e3738043d16a59a75b3bd15b29e31c554a83508d9af31caf1b526e3c535a243bcf77c8d77f9bf5be69f5b SHA512 834002c4e9c8ad36baa9a4ed494fe28cf09460e0ee5a0a3d8d111cb0bd8ca4ed3c784a047901bc67984e7892f931b5644c1ea68112e4d9dda514a20e048b3d11
diff --git a/dev-python/exdown/exdown-0.9.0.ebuild b/dev-python/exdown/exdown-0.9.0.ebuild
new file mode 100644
index 000000000000..c1f7fb4961a0
--- /dev/null
+++ b/dev-python/exdown/exdown-0.9.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+MY_P=pytest-codeblocks-${PV}
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/pytest-codeblocks/"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)
+"
+
+distutils_enable_tests pytest