summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-31 20:50:07 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-01 08:09:59 -0400
commite647b476018a2f9e16c9c507ffd02fad8121aa45 (patch)
tree8c018770ef51e3e484264a3acdc35dc00afc7ad3 /dev-python/fabric
parentdev-python/invoke: explicitly load pytest-relaxed plugin (diff)
downloadgentoo-e647b476018a2f9e16c9c507ffd02fad8121aa45.tar.gz
gentoo-e647b476018a2f9e16c9c507ffd02fad8121aa45.tar.bz2
gentoo-e647b476018a2f9e16c9c507ffd02fad8121aa45.zip
dev-python/fabric: load pytest-relaxed plugin explicitly
Bug: https://bugs.gentoo.org/661218 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/fabric-2.2.1.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/fabric/fabric-2.2.1.ebuild b/dev-python/fabric/fabric-2.2.1.ebuild
index dddf7851f843..00240b6a9c12 100644
--- a/dev-python/fabric/fabric-2.2.1.ebuild
+++ b/dev-python/fabric/fabric-2.2.1.ebuild
@@ -52,7 +52,8 @@ python_compile_all() {
}
python_test() {
- ${EPYTHON} -m pytest -s -v || die "Tests failed"
+ # -p pytest_relaxed: this plugin has to be loaded explicitly
+ pytest -s -v -p pytest_relaxed.plugin || die "Tests failed"
}
python_install_all() {