summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-12-27 13:01:27 +0200
committerAaron Bauman <bman@gentoo.org>2019-12-29 16:44:08 -0500
commit8dffe5c2869c10321888a3e362b014e3cadf6d32 (patch)
tree81a7b16a2a8912139f0c34fa04ecdc83f2307f2b /dev-python/fuse-python/fuse-python-1.0.0.ebuild
parentdev-libs/libedit: arm64 stable (bug #704116) (diff)
downloadgentoo-8dffe5c2869c10321888a3e362b014e3cadf6d32.tar.gz
gentoo-8dffe5c2869c10321888a3e362b014e3cadf6d32.tar.bz2
gentoo-8dffe5c2869c10321888a3e362b014e3cadf6d32.zip
dev-python/fuse-python: bump v1.0.0
- add PyPy3 support - add Python3.8 support Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14136 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python/fuse-python/fuse-python-1.0.0.ebuild')
-rw-r--r--dev-python/fuse-python/fuse-python-1.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/fuse-python/fuse-python-1.0.0.ebuild b/dev-python/fuse-python/fuse-python-1.0.0.ebuild
new file mode 100644
index 000000000000..002e6b7797bf
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/python-fuse-${PV}"