summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-06 09:20:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-06 09:20:01 +0200
commitf1c527fddec630d4a20ac33b5e47aaf686973e9e (patch)
tree1d084e37b41ab00c4c9838fbc75ba437a77f3eca /dev-python/google-api-python-client
parentdev-python/jupyter_client: Bump to 7.0.6 (diff)
downloadgentoo-f1c527fddec630d4a20ac33b5e47aaf686973e9e.tar.gz
gentoo-f1c527fddec630d4a20ac33b5e47aaf686973e9e.tar.bz2
gentoo-f1c527fddec630d4a20ac33b5e47aaf686973e9e.zip
dev-python/google-api-python-client: Bump to 2.24.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 4f81d600451a..d49b487145f3 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -3,3 +3,4 @@ DIST google-api-python-client-2.20.0.tar.gz 26723285 BLAKE2B 3c0cb64ea8c58fe2035
DIST google-api-python-client-2.21.0.tar.gz 26754841 BLAKE2B e09b48d80d72e56656b366bd60972cde91d0c705ffe94b61d168e808e575a42f1dbbefdaf21ead1e57bab54a1b2453ba39ed5ae1d2ee616a5ba1418acc9f7534 SHA512 c572e5eab313e01ae94b026e32cf40fb479154942168cc09f2b74f184383ff5fc27cc5c0ae48c34d8ddbd8abe8840520a62a43708bd601341d5b32460f5f07df
DIST google-api-python-client-2.22.0.tar.gz 26831856 BLAKE2B da93f1bca651cc01819c5f5ab43a6c767662db7eb85efb9aa08d2f9b54bc9efcc7622bff3207604ffafea9c88de8a393f5084c225078d896da5fdee1f2e56350 SHA512 427ead4173ed14b2df0560e35c5ff48a98d4abb5d449c26f84d9e7bb169bf46402eaaea0dab7988dbefd5ceee975b19a160cd797d2169030bb5bf1a54accda11
DIST google-api-python-client-2.23.0.tar.gz 26877979 BLAKE2B 64ae1132f8d380e15b5856c7b7683ceb7bf6f0f65400b2407195be7e30a0982288a0f7892e70b659c0984823d5dd0c3d4115eb781643a584091580ac1ed480b4 SHA512 da8515a0db759cfa4e9b991fd04811e9d213a35c184e993e2439e00860ce86857c2968da75dee3ec755a2f679ab44219d4cc1ed817e7ac24664e667412205566
+DIST google-api-python-client-2.24.0.tar.gz 27072085 BLAKE2B 285da09fff461ffd100a5fe603f970fab6d552197690279e0c0d411700b95109bde523c1cba84a3fbc04cdf7bc13237a4432014912e0c79aec0c1d82e42c8c69 SHA512 84f0e0f95de0bede13e76eac3885b2a40a61d3ad522cb11a59cd3ab1d7bf6a7368a21232f9a9f64905bfaa2bd7a9b359ee3dee2a53e1dc303e8aede14dbdd466
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild
new file mode 100644
index 000000000000..2bf8009bdc63
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.24.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+src_prepare() {
+ find tests -name '*.py' -exec \
+ sed -i -e 's:unittest2 as ::' {} + || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest tests ${deselect[@]/#/--deselect }
+}