summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-25 19:33:33 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-26 10:40:13 +0800
commit5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93 (patch)
tree593dbfb1dec6b547e33afc11099d4a93c0545bed /dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
parentdev-python/requests-oauthlib: bump 1.3.0 (diff)
downloadgentoo-5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93.tar.gz
gentoo-5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93.tar.bz2
gentoo-5c8f4c07468c38a21ecebaa57f9b7d8f8e335d93.zip
dev-python/google-auth-oauthlib: bump 0.4.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild')
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
new file mode 100644
index 000000000000..b16d9dabf656
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"