summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-17 08:23:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-17 08:47:53 +0100
commitd43a25e436421800d22963c8e3a9aa04582f857c (patch)
tree94c5e774f2db2196199ab9ddd0e0b49c0d791ab7 /dev-python/google-auth/google-auth-1.28.0.ebuild
parentdev-python/responses: Bump to 0.13.0 (diff)
downloadgentoo-d43a25e436421800d22963c8e3a9aa04582f857c.tar.gz
gentoo-d43a25e436421800d22963c8e3a9aa04582f857c.tar.bz2
gentoo-d43a25e436421800d22963c8e3a9aa04582f857c.zip
dev-python/google-auth: Bump to 1.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth/google-auth-1.28.0.ebuild')
-rw-r--r--dev-python/google-auth/google-auth-1.28.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-auth/google-auth-1.28.0.ebuild b/dev-python/google-auth/google-auth-1.28.0.ebuild
new file mode 100644
index 000000000000..400d08da8e38
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.28.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}