summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-01 20:51:19 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:51 -0700
commit2805ae78f536b871bb830f5939f833208053d30c (patch)
tree77a0a6cb1cb510d96cd382005965e476dddae8d2 /dev-python/helpdev/helpdev-0.7.1.ebuild
parentdev-python/geventhttpclient: arm64 stable (bug #731394) (diff)
downloadgentoo-2805ae78f536b871bb830f5939f833208053d30c.tar.gz
gentoo-2805ae78f536b871bb830f5939f833208053d30c.tar.bz2
gentoo-2805ae78f536b871bb830f5939f833208053d30c.zip
dev-python/helpdev: version bump 0.7.1, add py3_8,9
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/16540 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/helpdev/helpdev-0.7.1.ebuild')
-rw-r--r--dev-python/helpdev/helpdev-0.7.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/helpdev/helpdev-0.7.1.ebuild b/dev-python/helpdev/helpdev-0.7.1.ebuild
new file mode 100644
index 000000000000..48dabc7184c9
--- /dev/null
+++ b/dev-python/helpdev/helpdev-0.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Helping users and developers to get information about the environment"
+HOMEPAGE="https://gitlab.com/dpizetta/helpdev"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_{6,7,8} )
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest