summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 08:55:25 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 09:53:12 +0200
commita5350b9a4884eb26068d25846f1efd28805077f4 (patch)
tree15ee1dfff506a24f0dadc6e0edf3ccf61478a99c /dev-python/humanfriendly/humanfriendly-1.35.ebuild
parentdev-python/humanfriendly: Drop old (diff)
downloadgentoo-a5350b9a4884eb26068d25846f1efd28805077f4.tar.gz
gentoo-a5350b9a4884eb26068d25846f1efd28805077f4.tar.bz2
gentoo-a5350b9a4884eb26068d25846f1efd28805077f4.zip
dev-python/humanfriendly: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/humanfriendly/humanfriendly-1.35.ebuild')
-rw-r--r--dev-python/humanfriendly/humanfriendly-1.35.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/humanfriendly/humanfriendly-1.35.ebuild b/dev-python/humanfriendly/humanfriendly-1.35.ebuild
new file mode 100644
index 000000000000..34fa7dd29e0a
--- /dev/null
+++ b/dev-python/humanfriendly/humanfriendly-1.35.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Human friendly output for text interfaces using Python"
+HOMEPAGE="https://pypi.python.org/pypi/humanfriendly https://humanfriendly.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die
+}