summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:15:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-06 08:15:48 +0300
commit0f675dc86c187b3178bc70f86e9ab621399413b6 (patch)
tree6dd892ee1dd37856c4b8555f4ae3148931fd2917 /dev-python/jc/jc-1.20.2.ebuild
parentdev-python/botocore: add 1.27.23 (diff)
downloadgentoo-0f675dc86c187b3178bc70f86e9ab621399413b6.tar.gz
gentoo-0f675dc86c187b3178bc70f86e9ab621399413b6.tar.bz2
gentoo-0f675dc86c187b3178bc70f86e9ab621399413b6.zip
dev-python/jc: add 1.20.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jc/jc-1.20.2.ebuild')
-rw-r--r--dev-python/jc/jc-1.20.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jc/jc-1.20.2.ebuild b/dev-python/jc/jc-1.20.2.ebuild
new file mode 100644
index 000000000000..7b7bbfc30991
--- /dev/null
+++ b/dev-python/jc/jc-1.20.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest