summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-16 05:54:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-16 05:54:54 +0200
commitcd92b222506e214de38832bab75d1424080b521d (patch)
tree37ac6747e7cfb1f881df071ef50ff2aebb3a6ea5 /dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
parentdev-python/kombu: Remove old (diff)
downloadgentoo-cd92b222506e214de38832bab75d1424080b521d.tar.gz
gentoo-cd92b222506e214de38832bab75d1424080b521d.tar.bz2
gentoo-cd92b222506e214de38832bab75d1424080b521d.zip
dev-python/jupyter-core: Bump to 5.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-core/jupyter-core-5.3.1.ebuild')
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.3.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild b/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
new file mode 100644
index 000000000000..f2aa50355f98
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest