summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-02 21:29:35 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-02 21:29:35 -0700
commitb767a1041a9587db2c50a847eef2c68a94393633 (patch)
treea8bc4bc1be6b63b11d542b455bb7f377eae04a60 /dev-python/ldap3/ldap3-2.2.3.ebuild
parentdev-python/psutil: version 5.2.2 (diff)
downloadgentoo-b767a1041a9587db2c50a847eef2c68a94393633.tar.gz
gentoo-b767a1041a9587db2c50a847eef2c68a94393633.tar.bz2
gentoo-b767a1041a9587db2c50a847eef2c68a94393633.zip
dev-python/ldap3: version bump to 2.2.3
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/ldap3/ldap3-2.2.3.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-2.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-2.2.3.ebuild b/dev-python/ldap3/ldap3-2.2.3.ebuild
new file mode 100644
index 000000000000..35f3ea68309b
--- /dev/null
+++ b/dev-python/ldap3/ldap3-2.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+# The tests are a mess, and the test config is not included in the
+# PyPi tarball (see https://travis-ci.org/cannatag/ldap3 and
+# https://github.com/cannatag/ldap3/blob/master/test/config.py).
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ nosetests -v -s test || die
+}